WhatsApp Outage/Delays

Incident Report for Grayscale

Resolved

This incident has been resolved
Posted Jun 15, 2026 - 10:11 EDT

Monitoring

A fix has been implemented and WhatsApp is currently in a status of recovering from the delays and failures.
Posted Jun 12, 2026 - 16:27 EDT

Identified

There is an incident as of this morning on the WhatsApp side where we are seeing delays and failures. Our carrier's engineers have been alerted and are investigating.
Posted Jun 12, 2026 - 12:20 EDT